CORRIGIR PROBLEMA: Seu servidor está executando o PHP versão 5.1.6, mas WordPress 3.2.1 requer pelo menos 5.2.4.

Aviso de tudo não é bem conhecido que para instalar ou fazer atualizaçãoA versão mais recente de A 3.2É necessário que o ser instalada uma nova versão do 5.2.4.

Se o servidor é instalar uma versão do PHP mais de 5.2.4 instalar a versão WordPress 3.2.1Aparecerá erro / a mensagem: "Seu servidor está executando o PHP versão 5.1.6, mas WordPress 3.2.1 requer pelo menos 5.2.4".
O problema pode ser resolvido de maneira muito simples com a atualização do PHP, mas antes de fazer isso algumas coisas devem ser consideradas. Primeiro, atualize PHP é possível em uma hospedagem compartilhada. Você deve ter acesso para atualizar administrator no servidor (Servidor Dedicado ou VPS). No segundo, antes de atualizar para documentar e deve estar ciente de que nova versão do PHP não dado erros de outros sites hospedados no servidor.

para é o sistema operacional mais amplamente utilizado para servidores web (Agreart e / WHMA) a mostrar-lhe como fazer atualizar para PHP 5.2.10 em CentOS 5.x 32 bits.

Atualize o PHP 5.1.x para 5.2.x em CentOS 5.x 32 bits

1. Verificar que pacotes / módulos estão instalados PHP (por exemplo, php-mcrypt), juntamente com o pacote padrão. Se houver, deve ser excluído ou actuzlizate.

Verificando pacotes instalados:

rpm -qa | grep php
old_php_version

2. Adicionar repositórios para Necessário atualizaçãoA versão do PHP.

nano /etc/yum.repos.d/CentOS-Testing.repo

O novo arquivo (CentOS-Testing.repo) Irá adicionar o seguinte código (copiar / colar):

[c5-testing] 
name=CentOS-5 Testing 
baseurl=http://dev.centos.org/centos/$releasever/testing/$basearch/ 
enabled=1 
gpgcheck=1 
gpgkey=http://dev.centos.org/centos/RPM-GPG-KEY-CentOS-testing 
includepkgs=php*

Ctrl + X para salvar o arquivo CentOS-Teste.repo.

3. Update PHP via yum:

yum update

4. Restart / httpd :

service httpd restart

depois restart httpd verifique a versão e os pacotes instalados:

new_php_version

Verifique se há erros em módulos / pacotes:

php -v

- Atualização do PHP / CentOS 32 bits (i386).

Como » Linux » CORRIGIR PROBLEMA: Seu servidor está executando o PHP versão 5.1.6, mas WordPress 3.2.1 requer pelo menos 5.2.4.

Fundador e editor Stealth Settings, de 2006 até o presente. Experiência em sistemas operacionais Linux (Especialmente CentOS), Mac OS X, Windows XP> Windows 10 si WordPress (CMS).

Deixe um comentário