Corrigir erro: Sua instalação do PHP parece estar com a extensão MySQL exigida pelo WordPress

"Parece que a sua instalação do PHP está ausente da extensão MySQL exigida pelo WordPress”É um erro encontrado por muitos proprietários de blogs e sites com WordPress.
Este não é um motivo de preocupação. Falta de extensão MySQL do PHP é típico de sistemas operacionais instalados a partir do zero, VPS ou servidores dedicados, onde as extensões PHP não faziam parte do pacote de instalação. Esse problema está presente nos dois Ubuntu eo CentOS. Neste cenário, o problema é resolvido de forma muito simples com uma atualização do PHP e a instalação do módulo "php-mysql".
Atualize o PHP e instale a extensão MySQL no Ubuntu

apt-get update
apt-get install php-mysql

Atualize o PHP e instale a extensão MySQL no CentOS

yum update
yum install php70w-mysql

Após esta etapa, reinicie o serviço Apache ou NGINX.

Eu também encontrei o cenário em que, embora a extensão MySQL exista em PHP, um blog criado no WordPress exibia o erro "Sua instalação do PHP parece não ter a extensão MySQL exigida pelo WordPress". Na maioria das vezes, o erro ocorre durante a instalação do WordPress. Desta vez, porém, ele apareceu em um blog que estava ativo há vários anos.
Nesta situação, descobri que o problema não é com os módulos PHP, mas com a versão muito antiga do WordPress, que não é mais compatível com o PHP 7.4.4RC1. Uma simples atualização do WordPress para a versão mais recente resolveu o erro.

Corrigir erro: Sua instalação do PHP parece estar com a extensão MySQL exigida pelo WordPress

Sobre o autor

discrição

Apaixonado por tudo que é gadget e TI, escrevo com prazer em discriçãosettings.com desde 2006 e gosto de descobrir com vocês coisas novas sobre computadores e sistemas operacionais macOS, Linux, Windows, iOS e Android.

Deixe um comentário